
Overview 
Many features have been added to the JuiceCalculator since the rollout of Version 1. While new 
features add additional functionality, it can also make the calculator intimidating to use for the 
new user. The intent of this document is to provide instructions on how the new user can begin 
using the calculator (ignoring the advanced features) and later in the document I will start 
describing how you can use the other features.  

 
The basics 

Do you mix by weight? If so, let’s change an option so that you can see the results of your recipe 
in grams (in addition to volume and drops). 

 From the main window click the “Tools->Options” menu item. 

 Select the “Recipe defaults” tab. 

 Make sure that “Don’t show grams” is unchecked. 

 Click the “Save Defaults” and return to the main window. 
 
Creating your first recipe from scratch 

I am only going to step you through the minimum steps to create your first recipe and ignore all 
optional features and values. 
 
The steps we are going to perform are: 
1. Create our ingredients (Flavor and nicotine) 
2. Create our recipe 
3. Save the recipe (more on this later) 
 
Create ingredients (Flavor ingredients) 
 
If you are on the main window, launch the ingredient editor window by clicking the 
“Ingredients” button at the top of the main window. This will open the ingredient editor. 
 
1. At the top of the Ingredients window is a “New” button. Click it to create an ingredient. 
2. After clicking the new button you will be prompted to enter the name of the ingredient. 

Enter something such as “Double RY4”. Ignore the “Manufacturer” name, it is an advanced 
feature. 

3. Click the “OK” button to return to the Ingredient window. You should notice that the name 
you provided is listed in the “Ingredient Name” box. 

4. If you are defining a “flavor” ingredient that is 100% PG, you are done, click the “Save” 
button and go back to step 2 and add more ingredients. 

5. If your ingredient is not 100% PG, change the “PG Percentage” and “VG Percentage” values. 
6. If you are mixing by weight, provide a value for “Grams per ml”. You can do this by entering 

the value (usually around 1 gram/ml) or you can click the “Calculate weight based on PG/VG 
%” button. This button will use the known weights of PG and VG and use the percentage 
PG/VG percentages of the ingredient to calculate the ingredients weight. 

7. Click the “Save” button and go back to step 2 to add more ingredients. 
 
Create ingredients (Nicotine) 
 
If you are on the main window, launch the ingredient editor window by clicking the 
“Ingredients” button at the top of the main window. This will open the ingredient editor. 



Note that these steps are identical to the steps for adding a flavor ingredient with a couple of 
changes. 
 
1. At the top of the Ingredients window is a “New” button. Click it to create an ingredient. 
2. After clicking the new button you will be prompted to enter the name of the ingredient. 

Enter something such as “My Nicotine”. Ignore the “Manufacturer” name, it is an advanced 
feature. 

3. Click the “OK” button to return to the Ingredient window. You should notice that the name 
you provided is listed in the “Ingredient Name” box. 

4. By default the ingredient type is set to “Flavor”, check it to “Nicotine” by clicking the radio 
button. 

5. If your nicotine is not 100% PG, change the “PG Percentage” and “VG Percentage” values. 
6. Enter the “Nicotine Level (mg/ml)” value. 
7. If you are mixing by weight, provide a value for “Grams per ml”. You can do this by entering 

the value (usually around 1 gram/ml) or you can click the “Calculate weight based on PG/VG 
%” button. This button will use the known weights of PG and VG and use the percentage 
PG/VG percentages of the ingredient to calculate the ingredients weight. 

8. Click the “Save” button and go back to step 2 to add more ingredients. 
 
Create ingredients (PG & VG) 
 
PG and VG ingredients are created automatically and unless you are mixing by weight, there is 
nothing more you need to do. If you are mixing by weight: 
 
1. Select the PG entry from the “Ingredient Name” dropdown list.  
2. Provide the “Grams per ml” value or click the “Calculate weight based on PG/VG %” button. 
3. Click the “Save” button. 
4. Select the VG entry from the “Ingredient Name” dropdown list and provide the weight. 
 
Conclusion 
By now you should have created the ingredients that you will use in your first recipe. Notice that 
all of the ingredients that you created can be selected in the “Ingredient Name” dropdown list. 
Anytime you make changes to an ingredient value, click the “Save” button. Note that if you 
forget to click the “Save” button, you will be reminded when you attempt to leave the window 
or select another ingredient. 
 
Creating your first recipe 
 
If you are still in the ingredient editor window, click the “Exit” button to return to the main 
window. 
 
1. Click the “New” button at the top of the window.  
2. You will be prompted to provide a name for your recipe. Enter something such as “My first 

recipe” and click the OK button. 
3. The name you just entered is now displayed in the “Recipes” dropdown list. 
4. Enter the “Target Nicotine” value for your recipe. 
5. Enter the “Amount to make”. 



6. Select your nicotine ingredient from the “Nicotine” dropdown list or select “None” if you 
aren’t adding nicotine to your recipe. 

7. Enter the desired PG & VG percentage values for your recipe. 
8. If there are no “Flavor” lines being displayed, click the “Add Ingredient” button and select 

the ingredient to add. A “Flavor” line will be added to the window. 
9. Enter the desired percentage of the flavor that you want to add. 
10. If you want additional flavor ingredients continue clicking the “Add Ingredient” button and 

add the additional flavors.  
 
You have just created your first recipe by entering everything from scratch. You should have 
noticed that while you were updating your recipe values and adding ingredients that the recipe 
was being calculated automatically. There is no need to click a “Calculate” button. 
 
You will also notice that you will never see a red negative number displayed that other 
calculators may do. In the other calculators you are forced to figure out what data you entered 
incorrectly to make the red negative number go away.  
In this calculator there is a “Warnings and Errors” box. It will display descriptive messages telling 
you that your recipe can’t be properly calculated and what might be wrong. 
 
Another item worth noting is that there is no limit to the number of ingredients you can add to 
your recipe. If your ingredients won’t display in the window, a scrollbar is added so that you can 
scroll and view/update all of your ingredients. You can also enlarge the window to display more 
ingredient lines. 
 
Saving your work 
 
Other calculators save your recipes as individual files. While this has its advantages, it forces you 
to reenter all of your ingredients each time you create a new recipe.  
This calculator saves all of your recipes and ingredients into a single file which I will refer to as a 
“Juice file”. After you have defined your ingredients you can create new recipes using the 
ingredients that you already have defined. All of your work can be focused on the recipe instead 
of the individual ingredients.  
You might have reasons to create several juice files but remember, each juice file has its own set 
of ingredients. If you create new juice files you will have to enter all of the ingredients that you 
are going to use for recipes stored in that juice file. There are some advanced tools that can 
make this process easier but for now I am sticking to the basics to get you started. 
 
Let’s save the work we just did: 
1. If you have not yet created your juice file there should be a “Save as” button displayed at 

the top of the window. If you have created your juice file the button will be labeled “Save” 
which will save your changes to the existing juice file. Click the “Save as” button. 

2. When clicking “Save As” you will be prompted for a location to save the file and a name to 
assign to the file. Enter a name such as “All_of_my_recipes”. Remember, this is the filename 
not the name of a recipe stored in the file. 

 
Each time you launch the calculator it will automatically open the last juice file that you saved. It 
will also automatically display the last recipe that you were working with in the juice file. 
 



If by chance you want to create another juice file (not recommended for the new user), click the 
“File->Close” button and you will be provided with an empty juice file to start all over with. 
 
If you have been working with several juice files and you want to open a different juice file you 
can open it in one of two ways: 
1. Click the “File->Open recent” and see a list of recently used juice files. Select the one to 

open. 
2. Click the “File->Open” and navigate to the file you want to open. 

 
Creating recipes using recipes from another calculator 

 
Do you have recipes that you created in another calculator or did someone provide you with 
recipes that they created in another calculator? If so, this will walk you through how to “Import” 
the recipes and automatically create ingredients and recipes from the import. 
 
Note that there are three calculators that you can import recipes from: 
- EJuiceMeUp 
- EZMix 
- This calculator 
 
1. For EJuiceMeUp select “Tools->Import from EJuiceMeUp”.  
2. For EZMix select “Tools->Import from EZMix”. 
3. For this calculator select “Tools->Import EJC Recipe File (.XML file)”. 
4. For both the EJuiceMeUp and the “EZMix” recipe files, navigate to the file and select it. The 

ingredients from that file will be added to the opened juice file and the recipe will be added. 
5. For the “EJC Recipe File”, you will be prompted to: 

a. Select the file name (Import from file) 
b. After the file is opened, you will be prompted to select the individual recipes that 

you want to import. 
 

Save your changes. See my notes earlier on how to save you juice data file. 
 
Still the basics but optional features you may want to consider using 

 
Notes – You probably noticed that on both the recipe window and the ingredient editor window 
that there was a “Notes” area. Use this area to enter notes about your recipe and/or 
ingredients. 

Are you one of the users that like to type a lot of notes for a recipe and the window 
provided is not large enough to hold all of your notes? Click the “D” button under the 
“Notes” label. Notice how your “Notes” are detached from the recipe window and you 
have a new window completely dedicated to your notes. 
When you are ready to put your notes back into the main window either close the notes 
window and all of your changes will be put back or click the “D” button again and the 
window will be closed and put back. 

 
Rating – On the main recipe window you may have noticed a “Rating” box. In this box you can 
enter a number from 1 to 5 to rate your recipe. When you have provided a rating for a recipe 



you will notice green circles appearing with the recipe name. The number of circles represent 
the rating value. 
 
“View->Sort Recipes” – This menu option allows you to select the order that recipes are 
displayed when you click the “Recipes” dropdown list on the main window. You can sort them 
by: 
- Alphabetical order by recipe name 
- By date on when the recipe was added to the juice file. 
- By rating assigned to the recipe. 
 
“View->Sort recipe ingredients” – This applies to the ingredients displayed in your recipe. The 
ingredients displayed in the recipe can be ordered by: 
- Alphabetical by ingredient name 
- Displayed in the order that you added them to the recipe 
- Displayed based on the percentage value of the ingredient in the recipe 

 
File->Print Recipe – Used to print a copy of your recipe. 
 
File->Print Ingredients – Used to print a copy of all of your ingredients. 
 
Exporting to Excel – “Tools->Export to Excel” allow you to export all of your recipes and 
ingredients to an Excel workbook. If you do not have Excel installed you can still export to a 
“.xlsx” file and open it via applications such as “Open Office”. 
 
Simple calculators – “Tools->Simple calculators” allows you to launch one of several calculators. 
These calculators are standalone calculators that allow you to things such as diluting nicotine to 
a lower level. 
 
“Help->About” displays what version of the calculator you are running. 
 
“Help->Check for updates” will launch your browser and take you to the website where you can 
download new versions of the calculator. 

 
Advanced features 

 
Costs 

The calculator has the ability to calculate the cost of your recipes. Obviously, in order to 
use this feature there is some additional data entry that you must do to provide the cost 
of each of your individual ingredients.  
 
1. Launch the ingredient editor by clicking on the “Ingredients” button on the main 

recipe window. 
2. Select an ingredient from the “Ingredient name” dropdown list. 
3. In the “Cost” section of the window there are two values that you need to provide. 

a. Cost – This is the amount that you paid for the bottle of the ingredient. 
b. ML’s – This is the number of ML’s in the bottle. 

 



When your recipes are displayed in the main recipe window, the total cost of the recipe 
will be displayed in the “Results” area.  
If there are ingredients in the recipe that you have not added the “Cost” figures for, a 
warning message will be displayed in the “Warnings and Errors” area of the window 
telling you that “Cost/ml was not provided for all ingredients”. 

 
Manufacturer 

Most of us have ordered juices produced by different manufacturers such as “TFA”, 
“TPA”, “FW”, “Hangsen”, etc… We have also order flavors with the same name such as 
RY4 from Hangsen and RY4 from TFA.  
With the other calculators you have to enter a name for your ingredient that includes 
the manufacturer name so that you know which flavor ingredient you are using.  
With this calculator you can associate a manufacturer with an ingredient and name the 
ingredient for both manufacturers as “RY4”. To do this: 
1. From the main recipe window select the “Edit->Maintain manufacturer list”. 
2. A new window is displayed allowing you to create manufacturer entries. Go through 

and create, modify and/or delete the entries you want to maintain. 
3. There is a handy feature at the bottom of this window for finding and renaming 

your existing ingredients. Let’s assume that you entered (or imported) ingredients 
with names such as “TFA – RY4” or “Hangsen – RY4”. 

a. Select the manufacturer that you are setting up in the “Name” dropdown 
list. In this example select “TFA”. 

b. In the “Search ingredient value” box, enter the value “TFA –“. 
c. Optionally select the “Remove search value from ingredient name”. 
d. Click the “Search” button. 

i. All ingredients that have “TFA –“ in its name will be associated to 
the TFA manufacturer. 

ii. If you selected the “Remove search value from ingredient name”, 
the ingredient will be renamed and the “TFA –“ will be removed 
from the name. 

 
After you have defined your manufactures you can also manually update your 
ingredients and associated them to the manufacturer. In the ingredient editor there is a 
“Manufacturer” dropdown. Select the manufacturer and it will be associated to the 
ingredient. 
Also, when you are adding new ingredients by clicking the “New” button on the 
ingredient editor window you can select the manufacturer at the same time that you 
enter the ingredient name. 
 
Now that I have added manufacturers to my ingredients what good is it? 

Click the “View->Display ingredient/manufacturer as” menu item from the main 
recipe window. Notice that you have several options. This option will determine 
how the ingredient names are displayed throughout the calculator program. 
You can elect to display your ingredients as: 

RY4 (TFA) 
(TFA) RY4 
RY4 – TFA 
TFA – RY4 



RY4  (don’t show the manufacturer) 
 
This “View” option works hand and hand with another “View” option.  
“View->Sort Ingredients” – There are several options for sorting your 
ingredients when they are displayed in the dropdown list. The sort can include 
the manufacturer name. 

 
Inventory 

The calculator has the ability to track how much of an ingredient you have remaining 
and it can trigger warning messages when your volume is getting low so that you can 
reorder. To enable this feature: 
 
1. Click on the “Tools->Options” and select the “Ingredient defaults” tab. 
2. Check the “Display inventory messages”. 
3. Now you need to define how much inventory you have for each ingredient and at 

what level you want an alarm generated when the inventory falls below the 
threshold. 

a. In the ingredient editor window select an ingredient. 
b. Enter a value for “Inventory amount (ml) to reflect how much of the 

ingredient you have remaining. 
c. Enter a value for “Inventory alarm threshold”. When the inventory amount 

falls below this value a warning and/or alarm will be generated. 
 
Updating your inventory values 

Manual update – As described above, enter a value in the ingredient editor 
window. 
 
When updating costs – Let’s say that you just bought another bottle of an 
ingredient and you are entering the “costs” (described earlier under “Costs”). 
Notice a button labeled “Add to inventory”. When pressed, the ML value in the 
cost area will be added to the “Inventory amount” value for the ingredient. 
 
From the recipe window – Notice on the main recipe window an “Inventory” 
button on the top of the window. Click this button when you have a recipe 
displayed and you will be provided a window that will allow you to “Reduce 
inventory amounts” or “Add amounts back to inventory”. This will reduce or 
increase the inventory amounts by the amounts of each ingredient called for in 
the recipe. 

 
Displaying a ‘snapshot’ of all of your current inventory 

Click on “View->Current inventory” and a window will be launched showing all 
of your ingredients and the amount of each ingredient that you have remaining. 

 
Printing a list of your current inventory 

Click “File->Print inventory” to print the list of your current inventory amounts. 
 

Shopping list 



If you have an ingredient displayed in the ingredient editor window and you want to 
make a “log” entry to remind you to order more of the ingredient, click the “Add to 
shopping list” button.  
Notice a field in the ingredient editor called “Vendor”. If you provide the name of a 
vendor in this field it will be added to your shopping list for the ingredient. 
 
To display your shopping list click on the “View->Shopping list” menu item from the 
main window. From this window you can see ingredients that you added from the 
ingredient editor window and also: 
o Manually enter other items to the list 
o Remove items from the list 
o Search for all ingredients that are currently under their inventory threshold and add 

them to the list. 
 

Modify existing recipe 
This window is launched by clicking the “Tools->Modify existing recipe” menu item from 
the main window. The recipe that you currently have displayed will be loaded into the 
window. From this window you can: 
o Alter the PG/VG percentages of a recipe that you have already mixed. 
o Alter the Nicotine level of a recipe that you have already mixed. 
o Increase flavor percentages of the already mixed recipe. 
o Add additional flavors to the recipe. 
 
The window will calculate how much additional PG, VG, Nicotine and flavor ingredients 
that you need to add to the existing recipe to obtain the new levels. 
 
You should start by telling the calculator how much of the existing recipe you have 
“Amount of mix” and tell the calculator how much you want your final amount to be 
“Target amount”.  
Note that your target amount may be increased by the calculator. In order to obtain 
new levels additional volume must be added to the recipe and if the new values can’t be 
met with the amount that you have entered, the target amount will automatically 
increase. If the target amount is adjusted, messages will be displayed in the “log” area 
telling you what was changed. 
 
After you have made your changes you can either print the modified recipe or save the 
modified recipe under a new name. 

 
Merge two recipes 

Have you ever created recipes, mixed them, and then decided you didn’t like them and 
later wanted to mix two of these recipes together? This calculator will allow you to 
specify how much of each of the recipes you want to mix and it will create a recipe of 
the results of combining the two. Click on “Tools->Merge two recipes” menu item to 
launch this calculator. 
After combining the recipes you have the option to save the results under a new recipe 
name. 

 
Adjust total flavor percentages 



This window is launched by clicking the “Edit->Adjust total flavor percentage”. The 
purpose of this calculator is to display all of the flavor ingredients that you have in a 
recipe and increase (or decrease) the total flavor percentage but keep the ratio of all of 
your flavors the same. After you make the adjustments you can save the updated flavor 
percentages back into the recipe. 

 
Build recipe from ingredient amounts 

Are you one of those people that sits down and started throwing ingredients into a 
bottle and make something that you want to be able to repeat. If so, this calculator is 
for you. Launch this window by clicking “Tools->Build recipe from ingredient amounts”.  
Instead of creating a recipe by entering percentages, this window allows you to enter 
volume, drops or grams of each ingredient. When you save the recipe all of the amounts 
will be used to calculate a recipe in percentage amounts. 

 
Features still to document in a later version of this document 

- Designing and printing labels 
- Backup and restore 
- Ingredient editor (spreadsheet style) 
- Find and replace ingredients 
- Search for recipes using specific ingredients 
- All of the other “Options” that are available 
- File maintenance (secondary program) 


